Not possible to save contactlist
Incident Report for Saysimple Status
Resolved
This issue has been resolved.
Posted Jul 26, 2024 - 14:29 CEST
Identified
We discovered a bug which causes a problem whereby it's not possible to save contactlists. We're working on a fix and will provide you with further updates as soon as possible.
Posted Jul 25, 2024 - 14:15 CEST
This incident affected: Saysimple platform dashboard.