Login disruption
Incident Report for Saysimple Status
Resolved
The incident has been resolved. Users are able to login again. If you still experience issues with loging in, please contact us via support@saysimple.com and via phone or WhatsApp on +31 (0) 23 554 67 66.
Posted Feb 10, 2023 - 09:29 CET
Identified
We're currently experiencing an issue with logging in to the platform. We will resolve this as soon as possible.
Posted Feb 10, 2023 - 09:19 CET
This incident affected: Saysimple platform dashboard.