The loading time issue has been fully resolved. Platform performance is back to normal. Apologies for this inconvenience.
Posted Apr 22, 2025 - 16:08 CEST
Monitoring
The issue causing slow loading times on the platform has been resolved. Our development team has implemented a fix, and performance has returned to normal. Thank you for your patience!
Posted Apr 22, 2025 - 14:58 CEST
Investigating
We are aware of an issue causing slow loading times on the platform. Our development team is actively investigating and working toward a resolution. Further updates will be shared as soon as they become available.
Posted Apr 22, 2025 - 14:21 CEST
This incident affected: Saysimple platform dashboard.